Checkstep

Support centerSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Lag while analysing content
Resolved·Degraded performance

The latency of the provider is back to normal since a couple of hours

Thu, May 21, 2026, 06:08 PM
(3 minutes ago)
·
Affected components
01:30 PM
03:42 PM
App
Updates

Resolved

The latency of the provider is back to normal since a couple of hours

Thu, May 21, 2026, 06:08 PM

Monitoring

All the pending content was processed and there are no more lag. The provider is still slowest than usual, we are measuring and monitoring

Thu, May 21, 2026, 03:42 PM(2 hours earlier)

Identified

One of the scanning provider is slower than usual, we are closely monitoring the situation

Thu, May 21, 2026, 02:17 PM(1 hour earlier)

Identified

Dear valued customer,

We are currently investigating an issue affecting Checkstep services.

Incident Summary:
We have identified a potential service disruption beginning at 1:30 PM UTC. This incident is currently impacting:

  • Content scanning

Our engineering team is actively working to identify the root cause and implement a fix. We will provide updates every 4 hours or as soon as more information becomes available.

You can track real-time updates on our status page:
👉 https://status.checkstep.com

We apologize for the inconvenience and appreciate your patience as we work to resolve the issue.

Thu, May 21, 2026, 01:59 PM(17 minutes earlier)