Resolved
Processing delay is back to normal
Monitoring
Dear valued customer,
We are currently processing an usual large amount of contents, creating a delay to reflect change made to case in the UI. This delay should disappear during the next hour
You can track real-time updates on our status page:
👉 https://status.checkstep.com
We apologize for the inconvenience and appreciate your patience.